Updating opengl on ubuntu No cc message and fuck free

03 Apr

Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: account-plugin-windows-live libupstart1 Use 'apt-get autoremove' to remove them.

The following packages have been kept back: libdrm-dev libdrm-intel1 libdrm-intel1:i386 libdrm-nouveau2 libdrm-nouveau2:i386 libdrm-radeon1 libdrm-radeon1:i386 libdrm2 libdrm2:i386 libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles1-mesa libgles2-mesa libosmesa6 libosmesa6:i386 libva1 libwayland-egl1-mesa mesa-common-dev xserver-xorg-video-intel It appears that you have a version of Open Gl, just not one new enough to run the application that you are looking for.

.0 VGA compatible controller: Advanced Micro Devices, Inc.

[AMD/ATI] Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280] Subsystem: ASUSTe K Computer Inc.

Open GL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits) Open GL core profile version string: 3.3 (Core Profile) Mesa 13.0.1 Open GL core profile shading language version string: 3.30 Open GL core profile context flags: (none) Open GL core profile profile mask: core profile Open GL core profile extensions: Open GL version string: 3.0 Mesa 13.0.1 Open GL shading language version string: 1.30 Open GL context flags: (none) Open GL extensions: Open GL ES profile version string: Open GL ES 3.0 Mesa 13.0.1. However, it is not even clear that your app does not use a core profile.

If an application says it requires Open GL 3.2 and does not use a core profile. Have you actually tried running it with that enivornment variable?

That said, I see that we can soon expect kernel 4.8 for the 16.04.2 release, so maybe this problem will be fixed then.

If not, it is possible that your card does not support anything above Open GL 3.0, but you could look for a PPA to get a more up to date version of your driver.

SDL failed to create GL compatibility profile (which Profile=0!

PROBLEM: You appear to have Open GL 1.4.0, but we need at least 2.0.0!

There's even a thread that answers your question, though probably not in the way you would like.

Second, you "download this" by downloading and installing Intel's display drivers.